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[bookmark: _Toc190687693]Welcome
In this course, we provide guidance and introductory instructions on creating accessible  spreadsheets with Google Sheets. There are many elements that go into making content accessible; this guide is not exhaustive.
It is recommended that you review our training "Picking the Most Accessible Format for Your Content: PDF, Word, PowerPoint, or a Brightspace Page(opens in a new tab)" to ensure that a Google Sheets spreadsheet is the best format for your content.
The estimated time to complete this course is 10-15 minutes. 
[bookmark: _Toc190687694]Learning Objectives
By the end of this guide, you will be able to:
· Create tables with row headers.
· Describe inaccessible formatting practices and how to mitigate them.
· Generate descriptive alt text for images.
· Apply accessible layouts and labels to charts.
For more information about document accessibility, please reach out to CELT by emailing celt@stonybrook.edu(opens in a new tab).
If you come across an accessibility barrier in this guide, please let us know by emailing celt@stonybrook.edu(opens in a new tab).
[bookmark: _Toc190687695]Note on alternative text
This course provides alternative text through image descriptions either next to or below an image, and through the alt text tag for images in interactive content blocks.
[bookmark: _Toc190687696]Note on images
Select images to view them in a larger frame.
[bookmark: _Toc190687697]Note on links
All links in this course open to a new tab.
[bookmark: _Toc190687698]Tables, Labels, and Layout
[bookmark: _Toc190687699]Tables and Labels Simplify Complex Relationships
Tables can provide a means of presenting complex information in a manner that makes it easy to comprehend and identify relationships between the data points.
This is why it's important to have a clear purpose for each sheet, consistent and descriptive labels, and simple formatting to best organize information.
[image: ]
[bookmark: _Toc190687700]How to Create Accessible Tables
All tables need an identified header. To set the top row of your table as the header accessibly:
1. Select the cells you want to include in the table.
2. Click Insert>Tables.
3. Select the type of table you need based on the options in the Tables pane that will open on the right-hand side of the screen.
4. Type new, descriptive names for each column in the top row of the table.
[image: The Insert drop-down is open and the Tables option is noted with an arrow midway down the list.]
Figure 2 The Insert drop-down is open and the Tables option is noted with an arrow midway down the list.
While other software and content editing tools allow for multiple cells to be designated as  a header cell, Google Sheets only allows the first row of a sheet to be interpreted as the "Header row" within a table.
[bookmark: _Toc190687701]Naming Tables and Sheets
Naming tables and sheets in Google Sheets is important for maintaining clarity and organization, especially in complex sheets. When you assign meaningful names, it becomes easier to navigate and understand the data structure, reducing the risk of errors.
Named tables and sheets enhance the readability of formulas and references, making it simpler to audit and update your work. Well-named elements improve collaboration, as users can quickly grasp the purpose and content of each table or sheet, leading to more efficient teamwork and data management.
Naming a Table
1. Select the table that needs to be named.
2. Right-click the current name of the sheet.
3. Select Rename sheet from the drop-down.
4. Enter a unique name for the table in the textbox.
1. Note: your name must be one word with no breaks, you can use underscores if you want to connect more than one word.
5. Hit the enter button to finalize your entry and exit the textbox.
6. Repeat for all tables on the sheet (e.g. if you have a main table of data and a separate table for a key).
[image: A table's drop-down menu is open and the Rename table option is noted with an arrow.]
Figure 3 A table's drop-down menu is open and the Rename table option is noted with an arrow.
Naming a Sheet
1. Right-click on the sheet that needs to get renamed.  
2. Select the Rename option from the drop-down menu, the current sheet's name will become a textbox.
3. Enter the sheet's new and unique name in the textbox.
4. Hit the enter button to finalize the new name and close the textbox.
[image: Sheet drop-down is open and the Rename option is noted with an arrow.]
Figure 4 The Sheet drop-down is open and the Rename option is noted with an arrow.
[bookmark: _Toc190687702]Inaccessible Formatting Methods
There are some common formatting mistakes that you want to avoid:
Merging, nesting, and splitting cells
When tables contain merged cells and nested tables, each cell must be uniquely identified and associated with the appropriate header cell. MS Excel does not provide a means of doing this, so it is recommended that you keep your tables simple - for the sake of clear communication as well as for accessibility.
Control spacing in your table with blank rows or columns
When blank spaces are added in a table, some screen readers will "read" each empty cell to the user. That can take up a lot of their time and be disorienting for someone listening in. It is better to adjust the line spacing or use borders to create visual spaces between columns or rows.
Use tables for design layout
If there's no clear purpose or logical connection between each field in the table, it makes the information difficult to understand. This is when it's better to use Microsoft Word to convey information and content using its accessible tools and features.
Leaving extra empty sheets
If you initially created three sheets and only used two sheets, you want to delete the extra sheet. Leaving empty sheets with no data, labels, or headers can create confusion for users relying on a screen reader since there's no information to tell them that they can skip that sheet.
To remove a sheet:
1. Right-click on the sheet that needs to go.  
2. Select the Delete option from the drop-down menu.
[image: Figure 1.4. The Sheet drop-down is open and the Delete option is noted with an arrow.]
Figure 5 The Sheet drop-down is open and the Delete option is noted with an arrow.
Leaving blanks cells
You want to avoid leaving blank cells, columns, and rows as much as possible. A blank cell might lead a screen reader user to think they've reached the end of the table.
If you cannot avoid a blank cell, column, or row, you need to explain it's blank. For example, you can type "N/A" or "Intentionally Blank" in the cell.
Freezing rows or columns
Frozen rows and columns should be avoided whenever possible. They can make it difficult for screen reader users to navigate. For example, if someone uses a keyboard shortcut to go to "Home" after freezing the top row, they'll be taken to cell A2 instead of cell A1.
[bookmark: _Toc190687703]Knowledge Check 1: Tables, Labels, and Layout
Answer the following question to self-check your knowledge (answers are at the end of the document).  
1. Which of the following practices should be avoided to ensure table accessibility in Google Sheets? (Check all that apply). 
a. Merging cells
b. Using blank rows for spacing
c. Using tables for layout purposes
d. Leaving extra empty sheets
[bookmark: _Toc190687704]Summary
It's critical in Google sheets to convert your data to tables. This allows you to identify header rows and provide consistent labels to help show the relationships between data points and to best navigate the content.
Here are some key takeaways:
· Use clear and descriptive labels. This enhances understanding and navigation of data.
· Always set a header for your tables. This is crucial for accessibility and clarity.
· Avoid merging cells and using blank rows. These practices can hinder accessibility for screen readers.
· Name your tables and sheets meaningfully. This improves collaboration and reduces errors.
[bookmark: _Toc190687705]Cell Characteristics and Ranges
[bookmark: _Toc190687706]Why Cell Characteristics and Ranges Need to Be Set
It's key that cells are formatted properly to represent your data, including setting number and text attributes.
Setting these characteristics in Google Sheets allows for for precise data referencing, which enhances readability and ensures that assistive technologies can interpret and present the data effectively.
[image: A group of kids sitting at desks with laptops

Description automatically generated]
[bookmark: _Toc190687707]Formatting Cell Characteristics
1. Highlight the cells that you want to format. If it's a full row or column, select that row or column's indicator.
2. From the toolbar, select the icon or drop-down list for the format you would like to apply (e.g., Format as currency, Format as percent, More formats).
[image: A spreadsheet has cells highlighted and an arrow is pointing to the data formatting options in the toolbar.]
Figure 6 A spreadsheet has cells highlighted and an arrow is pointing to the data formatting options in the toolbar.
[bookmark: _Toc190687708]Setting Data Ranges
Naming the different data ranges in a table makes it easier to navigate the spreadsheet and find specific information. These ranges can be mentioned in several places of your document, as well as inside calculations and equations.
1. Select the cells you would like to name.
2. From the toolbar, go to Data > Named ranges. A menu will open on the right.
3. Type the unique and descriptive name of the range.
· Optional: to change the range, click the Spreadsheet Grid icon.
· Select a range in the spreadsheet or type the new range into the text box, then click Ok.
4. Click the Done button.
[image: The Data drop-down in the toolbar is open and the Named ranges option is noted with an arrow.]
Figure 7 The Data drop-down in the toolbar is open and the Named ranges option is noted with an arrow.
[bookmark: _Toc190687709]Google Ranges Article
Learn more about creating, editing, and deleting ranges in Google Sheets.
[bookmark: _Toc190687710]Knowledge Check 2: Cell Characteristics and Ranges
Answer the following question to self-check your knowledge (answers are at the end of the document).  
1. Why is it important to format cell characteristics in Google Sheets?
a. It makes the spreadsheet look more colorful.
b. It helps in precise data referencing and enhances readability.
c. It allows for faster data entry.
d. It prevents data from being deleted.
[bookmark: _Toc190687711]Summary
Setting cell characteristics and named ranges improve data readability and ensures accurate interpretation by assistive technologies.
Here are some key takeaways:
· Learn to highlight cells for formatting. Use the toolbar to apply desired formats like currency or percentage.
· Provide data ranges with unique names. This helps distinguish each range and see relationships between points.
[bookmark: _Toc190687712]Images
[image: ]
[bookmark: _Toc190687713]Make Images Accessible with Alt Text
Since our computers can't tell us what's in a picture, we have to include an image description when we create a document in order for it to be accessible.
The exact process you use to describe an image will change based on the document creation software you are using. On the other hand, the term "Alt Text" describing the textual description of an image is used across many tools.
[bookmark: _Toc190687714]How to Apply Alt Text
While Alt Text can be added to a variety of objects in Google Docs and Slides, only images can have Alt Text added in Google Sheets.
Images in a Cell
For images in a cell, you need to:
1. Right-click the image.
2. Select Image>Add Alt Text to cell from the drop-down menu.
3. In the Alt Text pane, enter your alt text in the Description textbox, and close the pane.
[image: A drop-down menu with the Image category opened and an arrow is indicating the Add alt text to cell option.]
Figure 8 A drop-down menu with the Image category opened and an arrow is indicating the Add alt text to cell option.
Images Over the Cells
For images placed over a cell, you need to:
1. In the top right corner of the image, click on the three dots.
2. Select Alt text from the drop-down menu.
3. In the Alt Text pane, enter your alt text in the Description textbox, and close the pane.
[image: An image over cells in a Google Sheet has the Image options drop-down open and the Alt Text option is noted with an arrow.]
Figure 9 An image over cells in a Google Sheet has the Image options drop-down open and the Alt Text option is noted with an arrow.
[bookmark: _Toc190687715]Title Vs. Description
When entering alt text, Google Sheets provides two distinct fields: Title and Description.
A screen reader can access both of these fields in Google Slides, but if you export to Microsoft Word and have content in both fields, the Title field will be removed and the Description field will remain intact. Therefore, instead of using the Title field, its better to only use the Description field to enter alternative text.
[bookmark: _Toc190687716]Mark an Image as Decorative or Null
When an image is decorative, meaning it does not add meaningful content or context, such as decorative borders or background images then it needs to be accordingly marked. When it is marked as decorative, screen readers will ignore the image, allowing users to navigate the document more efficiently without unnecessary interruptions.
In Google Docs, you need to enter two double quotation marks "" into the Alt Text>Description box.
Do not mark all images as decorative to expedite your remediation process. According to the WCAG guidelines, images should only be marked as decorative if they are not adding meaningful context to the image.
[bookmark: _Toc190687717]Image Placement
In order for images to be perceived and read by screen readers, they must be placed with the setting of "Insert image in cell." If images are set as "Insert image over cells," it cannot be reliably read by all screen readers and that content may be skipped.
[bookmark: _Toc190687718]Knowledge Check 3 Answers: Images
Answer the following question to self-check your knowledge (answers are at the end of the document).  
1. Why is it recommended to use the Description field instead of the Title field when entering alt text in Google Sheets?
a. Because the Title field is not accessible by screen readers
b. Because the Description field is retained when exporting to other formats
c. Because the Title field is only used for decorative images
d. Because the Description field provides more detailed information
[bookmark: _Toc190687719]Summary
Alt Text can be a valuable tool for conveying meaning and helping visualize imagery for screen reader users.
Here are some key takeaways:
· Use Alt Text to describe images for accessibility. It helps screen readers convey information to users.
· Use the Description field instead of the Title field for Alt Text in Google Sheets. The Description is retained in exports to Excel and PDF.
· Mark images as decorative only if they do not add meaningful content. This helps streamline navigation for users.
· Charts and graphs in Google Sheets cannot have Alt Text. Export them to other formats for accessibility remediation.
[bookmark: _Toc190687720]Charts, Graphs, and Maps
[bookmark: _Toc190687721]Adding Alt Text to Charts and Graphs
At this time, Google Sheets does not allow Alt Text to be added to charts, graphs, or maps. This means that any sheet containing these items is not fully accessible to screen reader users.
In order to share accessible sheets that contain charts, graphs, or maps the content developed in Google Sheets needs to be exported to Microsoft Excel or a PDF, which can be remediated to be accessible.
There are things you can do in Google Sheets to prepare your content that will make the export a smoother process.
[image: ]
[bookmark: _Toc190687722]Add Labels and Notes to Charts
Information is power when it comes to charts. The more detail you can provide to guide a reader through your data, the easier it will be to navigate the content.
Data labels are annotations that provide specific information about the data points plotted on a chart. They help users quickly understand the value or category each data point represents. For instance, in a bar chart showing sales figures, data labels might display the exact sales amount above or beside each bar. This makes it easier to interpret the chart without having to reference the axis or legend repeatedly.
Text notes are comments that you can attach to individual cells to provide additional context or information without altering the actual cell content. When you hover over the cell, the note will pop up, displaying your annotation. These are particularly useful for adding explanations, instructions, or reminders to specific data points without cluttering your spreadsheet.
Data Labels
1. Double-click the chart you want to change to open the Chart Editor, a panel on the right-hand side of the screen.
2. Click Customize>Series.
3. Check the Data labels checkbox.
Below the checkbox are a number of customization options for the data labels' font, color, and sizing.
[image: The Chart editor is open and there's an arrow pointing to the Data labels checkbox, which is checked to demonstrate best practice.]
Figure 10 The Chart editor is open and there's an arrow pointing to the Data labels checkbox, which is checked to demonstrate best practice.
Text Notes
Add notes to explain any data trends you're seeing.
1. Add text notes
· Add a column to the right of the data points you want to add notes to.
· Add your text notes in the column.
2. Add labels
· Double-click the chart you want to change to open the Chart Editor, a panel on the right-hand side of the screen.
· Click Setup.
· In the box under X-axis, click the More icon (three vertical dots).
· Select Add labels from the drop-down menu.
· Enter the data range that contains your notes.
[image: The "Chart editor" is open and the "More" icon is noted with an arrow under the X-axis options.]
Figure 11 The "Chart editor" is open and the "More" icon is noted with an arrow under the X-axis options.
[bookmark: _Toc190687723]Additional Resource
Google Charts Article
Learn more about labelling charts in Google Sheets.
[bookmark: _Toc190687724]When It's Time to Export
Training is available regarding how to complete these remediations  
Basic PDF Accessibility
Learn more about making PDFs accessible.
Basic Excel Accessibility
Learn more about making spreadsheets accessible.
[bookmark: _Toc190687725]Knowledge Check 4: Charts, Graphs, and Maps 
Answer the following question to self-check your knowledge (answers are at the end of the document).  
1. What is one way to prepare your Google Sheets content for a smoother export process?
a. Add Alt Text to charts and graphs
b. Add labels to charts
c. Remove all charts and graphs
d. Use only text-based data
[bookmark: _Toc190687726]Summary
In this lesson, we explored the limitations of Google Sheets regarding Alt Text for charts, graphs, and maps, and discussed how to prepare content for export to ensure accessibility. Here are some key takeaways:
1. Understand limitations. Google Sheets does not support Alt Text for charts and graphs.
2. Prepare data labels. Add labels to charts for better navigation.
3. Include text notes. Explain data trends effectively with notes.
4. Export for accessibility. Use Microsoft Excel or PDF for accessible remediation.
By following these strategies, you can ensure your data remains accessible to all users.
[bookmark: _Toc190687727]Conclusion
You have completed the Basic Google Sheets Accessibility course!
Please fill out the Feedback Survey Form to record your completion of this course and to provide feedback for improvements. 
[bookmark: _Toc190687728]Knowledge Check Answer Key
[bookmark: _Toc190687729]Knowledge Check 1 Answers: Tables, Labels, and Layout
1. A, B, C, and D
[bookmark: _Toc190687730]Knowledge Check 2 Answers: Cell Characteristics and Ranges
1. B
[bookmark: _Toc190687731]Knowledge Check 3 Answers: Images
1. B
[bookmark: _Toc190687732]Knowledge Check 4 Answers: Charts, Graphs, and Maps 
1. B
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